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Abstract— Cloud computing is a web-based service. It is shared pool of resources over the internet. Cloud is not any single 
entity but set cloud services, cloud storage, cloud infrastructure and clod platforms. This paper aims to describe use of cloud 
computing for online compiler providing portability and storage. By making use of online compiler developer can select the 
one which is convenient and gives fastest compilation result. This web-based application is platform independent and can be 
remotely accessed by network connection. This application is helpful for conducting online practical examination because of 
it reduces work of installing compilers on every system in lab. Intern reduces lab administration workload. Hence the system 
provides centralized storage and centralized compiling scheme. 
 
Keywords— academic institution, cloud computing, online compiler 
 
 
I. INTRODUCTION  
 
  Cloud computing provides the most efficient and 
adoptable technology now a days because of its 
advantages over the client server technology. Cloud 
Computing refers to application and services that run 
on a distributed network using virtualized resources 
and accessed by common internet protocols and 
networking standards. Cloud is on demand service 
where user simply requests for a resource he is willing 
to use for a particular period of time and then may 
release. Resources can be any software, hardware, 
platform required. It provides great flexibility to end 
user by simplifying their work, also economically 
beneficial. Two different classes of clouds: those 
based on deployment model and those based on 
service model. The deployment model tells you where 
the cloud is located and for what purpose. Public, 
private, community and hybrid clouds are deployment 
models. Service models describes the type of service 
that service provider is offering. Best known service 
models are Software as a service, platform as a 
service, and infrastructure as a service. 
A. SAAS: 

     Software requirements of clients are fulfilled 
with SAAS. Client can use software they need 
without installing on a personal system. 

B. PAAS: 
         Platform required for developing certain 
application is also provided on cloud with PAAS. 
Client gets specific platform like Linux OS or any 
other that they need for developing particular 
application. 
C. IAAS:  
     Hardware requirements are fulfilled with the 
IAAS. Client can demand for hardware configuration 
they required, in their application for some period of 
time can get from cloud.  
There are mainly three types of cloud for servicing 
different users: 
 

 
1. Public cloud: Public cloud can be setup within 

premises or out somewhere. Person from the 
same organization or different can access the 
services from public cloud. 

2. Private cloud: Private cloud setup establish 
within the premises only. Admin by the 
organization person and services of private 
cloud can be access by authorized nodes only. 

3. Hybrid cloud: Hybrid cloud is the combination 
of both private as well as public cloud. 

          
 

    
 
 
 
 
 

 
 
 
 
 
 

Fig. 1.  Cloud Computing. 
 
II. NEED FOR PROJECT 
 
     With cloud computing is that client is unaware 
from where he gets service and where the server is 
located. The main advantage of cloud computing is 
fastest processing Thus, keeping this main advantage 
in mind, the main reason for creating the project is to 
provide a centralized compiling scheme for 
organizations or institutions. Also, it will act as a 
centralized repository for all the codes written. The 
other major advantage that this system will have over 
the others is that it will make the users system 
lightweight i.e. there will be no need to maintain 
separate compilers/SDK’s client-side. Thus, for 
educational institutions this will prove to be highly 
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efficient. Also, the process of maintenance and 
distribution of dynamic usernames and passwords 
will be greatly simplified. Also, authentication and 
personalized task distribution will be made possible. 
Lab administration gets easy and lab maintenance 
problem can be easily avoided.Educational 
institutions this will prove to be highly efficient. 
Also, the process of maintenance and distribution of 
dynamic usernames and passwords will be greatly 
simplified. Also, authentication and personalized task 
distribution will be made possible.  
 
III. ONLINE COMPILER 
 

  
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 2.  Online Compiler Architecture                                                                                                                                                                                  
 
 To facilitate online compiling client has given 

primary functions which need to execute by client to 
execute their code: 

  Start option: Where editor is open and user can 
start writing code which the send to server for 
compilation. 

 Compile code: After code has been written it is 
now ready to compile .with the click for compile 
button code will get compiled and displays result 
whether successful or not.  

Execute code: With the execute button compiled 
code which is error-free get executed and results are 
displayed to client 

All the programs with the timing of compilation 
are stored in database maintained by the server. 
Administrator can watch all the movements of the 
client. Online complier is a simple compilation tool 
which compiles and executes code for user. The code 
written on client window is taken by online complier 
and executable file is stored in database.URL 
provided by online compiler will helps to download 
and access .exe file directly on user’s terminal. This 
feature will lead to server interact and be safe from 
damage. 
Deployment of private cloud suing Glassfish: 
     Private cloud is known as corporate cloud. It 
provides service to limited number of people who are 
registered. We are developing private cloud with 
glassfish server and we will deploy our online 
commuting model on that. Each user will be given a 
registration id and then all the services are accessible 

to him. He can create, store, execute his/her 
application on a server. Private cloud which is also 
known as internal cloud which marketing of 
computing resources that provides hosted services to 
a limited number of people. With the help of 
distributed computing and virtualization technique, 
data centre administrators and other corporate 
network to effectively become a service provider that 
meets the needs of their customers.  
 
IV. ARCHITECTURE 

 
     Online compiling system is layered architecture. 
First layer contains clients, with any manageable 
configuration or we can say any thin client. And other 
layer is server, where actually our online compiling 
module runs. And where cloud server is located. So 
every user account is created on cloud and database is 
managed for that.  
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Fig. 3.  Online Compiler Architecture                                                                                                                                       

  
  Architecture is developed and workout as follows: 

1. To provide a centralized compiling scheme 
for an organization or institution. 

2. Centralized storage for all the codes written. 
3. No need to maintain separate compilers or 

SDK’s at client side. 
4. User authentication and personalized task 

distribution. That is the administrator will be 
able to assign user-id, password & 
personalized tasks to all the clients. 
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5. The codes will be compiled centrally and the 
results will be displayed at client-side 
application. 

6. Both the error stream and output stream of 
the compiler will be captured and the output 
will be sent to client. 

7. Web services are used for communication 
between client and server. 

8. Glassfish is a web server used. 
9. A database of all the codes written by the 

clients will be maintained. 
10. A client may retrieve the stored-code at any 

later instance. 
11. The administrator will have full authority to 

compile & execute the codes stored by 
clients for evaluation. 

12. Statistical details of compilation time, 
execution time, etc. will be maintained at the 
server side. 

13. Extremely efficient for educational 
institutions since maintenance of compilers 
needs to be done at only server side. 

14. Direct comparison of outputs of all the 
clients can be done at the server side. 

15. A client may be assigned a different task 
every time he/she logs in depending on the 
will of the administrator. 

16. A client may be assigned a different task 
every time he/she logs in depending on the 
will of the administrator 

17. Efficient for conducting practical 
examinations, since every client will be 
assigned a different log in id and password. 

18. The administrator may create, edit and 
delete client profiles anytime. 

This is how workflow of the system goes: 
1. Sin in:-This module accepts the details of a 
1. new user and stores it in the database. This 

module ensures 
2. that the user is registered before the first 

login. 
3. Sin up:-A registered user should login with 

his 
4. username and password. This module 
5. facilitates login and user authentication 

using 
6. User Details DB database. This action is 

logged in the 
7. Logs database. 
2. Select Language:-In this step user will select 

the language in which he want to code and 
compile. 

3. Edit code: - Editing of a complete code will 
be done here. Code typing, updating, and all 
editing functions will be performed in this 
editing area. After editing user send that 
code for compiling. 

4. Compile request: - This module will compile 
the code and displays result. Errors are 

displayed in case if present any. This module 
works when it gets the request from client. 

5. Request send: - This stage will send the 
request from client to server using 
SOAP/XML protocol. 

6. Request receive: - Request is received by the 
server, then server will handle that request. 
It processes the request and store in 
database.  

7. Compiler interface: - This compiler interface 
module contains compiler respiratory, where 
all compilers are stored   

8. Compiler output: - Compiler generates 
output. If compiled correctly or errors are 
present, and displays them correspondingly 
for further processing. 

9. Response: - This compiled output should 
reach to the client this is nothing but 
response to the client from server. 

10. View compiled response: - Here compiled 
response is viewed by the client. This may 
be any kind of errors, message of 
compilation or result of execution. 

     The timing and response of all the above processes 
are stored and maintained in the database. And handle 
by the cloud server. 
 
V. IMPLEMENTATION 
 
      In this project development, the three important 
aspects need to be emphasized are java programming 
language, MySQL, and Glassfish server. The 
software that has been used in this project is java, 
MySQL, Glassfish is used to. It provides the web 
service to interact betwwn clint and server on netwok.   
MySQL is used as storage information system. 
 
Step 1:  Implementation of cloud from server (cloud 
server) 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 

Fig. 4.  Snapshot of cloud server 
Select File -> New Project -> Java Web -> Web 
Application 
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Step 2: Give name for project. 
 
Step 3: Select Glassfish Server. 
 
Step 4: Structure of a project will be created. 
 
Step 5: Right Click on default package and select 
             New -> Java Package. 
 
Step 6: Give name to the package. 
 
Step 7: Create a Web Service. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 5.  Snapshot of  web service 
       
New -> Others -> Web Services -> Web Service  
 
Step 8: Give name to web service and then server                     
application will be created. 
 
Step 9: Create client application 
             Select File -> New -> Java Application 
 
Step 10:  Give name to client application and 
structure will            be created. Then select default 
package. 
   Select New -> Java Package 
 
Step 11: Right click on client pack and select 
                New -> Jframe 
 
Step 12:  Create GUI 
 
Step 13: Right Click on 
               “Client Name” ->New -> Web Service 
Client 
 
Step 14: Select Server 
 
Step 15: Address of the server will appear as shown 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 6.  Snapshot of  server 
 
Step 16: Web Service reference will be added. 
 
Step 17: Drop a web service reference in code. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 7.  Snapshot of code area 
 

Step 18:  Structure of a function will be automatically        
created in your code. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Fig. 8.  Snapshot of functional code 

Step 19: With the GUI support we run our 
application. 
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Step 20: Finally we have successfully created our 
module on cloud.  
 
Advantages 

1. No need to download the SDK of any 
Compiler: When we want to execute any 
program we required a software 

2. Development kit of that particular program 
for example if user want to compile JAVA 
program then they required JDK. 

3. No issues of setting path variables: 
Sometimes there is requirement of setting 
path variable i.e. where the program is 
saved. 

4. Simple to use GUI for better coding: It 
provide better graphic user interface for 
coding i.e. editor. 

5. Mobility: No need to carry whole 
environment of our program. Internet 
connection on user system is only 
requirement. 

6. No need of storage space on your system: 
Everything is store on web server so there is 
no need of storage space of user system. 

 
 Disadvantage 
      1.  Cost is high because of Cloud Server. 

2.   Required Internet Connection. 
 
CONCLUSION 
 
     By integrating and enhancing the capabilities of 
these essential technologies, we hope to introduce the 
‘Online Compiler’ and to contribute to the current 
examination system.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

It would basically be a platform for students of the 
university to give their practical examinations online. 
There would be a cloud where there will be a server 
which would have the power to compile the student`s 
code stored on another machine.  
 
    As compared to the current scenario where each 
machine should have the C/C++ compiler installed 
separately and an examiner has to visit each machine 
to check each and every student`s code. This would 
eliminate the need to install compilers separately, the 
examiner does not need to visit each student but can 
check the codes at the centralized server as well as 
each students record is maintained for future 
references. Another advantage of such a project is 
that whenever the compiler package is to be upgraded 
it can be done easily without again installing it on 
each and every machine. 
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